#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)'(?:\.+\/)*([^']+)'"
Local $sString = "'./components/chunks/breadcrumbs/breadcrumbs.html'" & @CRLF & _
"'../../components/chunks/breadcrumbs/breadcrumbs.html'" & @CRLF & _
"'./../../components/chunks/breadcrumbs/breadcrumbs.html'" & @CRLF & _
"'../../../components/chunks/breadcrumbs/breadcrumbs.html'" & @CRLF & _
"'./../../../components/chunks/breadcrumbs/breadcrumbs.html'" & @CRLF & _
"'../../../../components/chunks/breadcrumbs/breadcrumbs.html'" & @CRLF & _
"" & @CRLF & _
"При любом уровне вложенности нужно получить" & @CRLF & _
"components/chunks/breadcrumbs/breadcrumbs.html"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)