package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'(?:\.+\/)*([^']+)'`)
var str = `'./components/chunks/breadcrumbs/breadcrumbs.html'
'../../components/chunks/breadcrumbs/breadcrumbs.html'
'./../../components/chunks/breadcrumbs/breadcrumbs.html'
'../../../components/chunks/breadcrumbs/breadcrumbs.html'
'./../../../components/chunks/breadcrumbs/breadcrumbs.html'
'../../../../components/chunks/breadcrumbs/breadcrumbs.html'
При любом уровне вложенности нужно получить
components/chunks/breadcrumbs/breadcrumbs.html`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}