use strict;
my $str = '\'./components/chunks/breadcrumbs/breadcrumbs.html\'
\'../../components/chunks/breadcrumbs/breadcrumbs.html\'
\'./../../components/chunks/breadcrumbs/breadcrumbs.html\'
\'../../../components/chunks/breadcrumbs/breadcrumbs.html\'
\'./../../../components/chunks/breadcrumbs/breadcrumbs.html\'
\'../../../../components/chunks/breadcrumbs/breadcrumbs.html\'
При любом уровне вложенности нужно получить
components/chunks/breadcrumbs/breadcrumbs.html';
my $regex = qr/'(?:\.+\/)*([^']+)'/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";