re = /'(?:\.+\/)*([^']+)'/m
str = '\'./components/chunks/breadcrumbs/breadcrumbs.html\'
\'../../components/chunks/breadcrumbs/breadcrumbs.html\'
\'./../../components/chunks/breadcrumbs/breadcrumbs.html\'
\'../../../components/chunks/breadcrumbs/breadcrumbs.html\'
\'./../../../components/chunks/breadcrumbs/breadcrumbs.html\'
\'../../../../components/chunks/breadcrumbs/breadcrumbs.html\'
При любом уровне вложенности нужно получить
components/chunks/breadcrumbs/breadcrumbs.html'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result