$re = '/\'(?:\.+\/)*([^\']+)\'/m';
$str = '\'./components/chunks/breadcrumbs/breadcrumbs.html\'
\'../../components/chunks/breadcrumbs/breadcrumbs.html\'
\'./../../components/chunks/breadcrumbs/breadcrumbs.html\'
\'../../../components/chunks/breadcrumbs/breadcrumbs.html\'
\'./../../../components/chunks/breadcrumbs/breadcrumbs.html\'
\'../../../../components/chunks/breadcrumbs/breadcrumbs.html\'
При любом уровне вложенности нужно получить
components/chunks/breadcrumbs/breadcrumbs.html';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;