using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'(?:\.+\/)*([^']+)'";
string substitution = @"$1";
string input = @"'./components/chunks/breadcrumbs/breadcrumbs.html'
'../../components/chunks/breadcrumbs/breadcrumbs.html'
'./../../components/chunks/breadcrumbs/breadcrumbs.html'
'../../../components/chunks/breadcrumbs/breadcrumbs.html'
'./../../../components/chunks/breadcrumbs/breadcrumbs.html'
'../../../../components/chunks/breadcrumbs/breadcrumbs.html'
При любом уровне вложенности нужно получить
components/chunks/breadcrumbs/breadcrumbs.html";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}