import Foundation
let pattern = #"'(?:\.+\/)*([^']+)'"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
'./components/chunks/breadcrumbs/breadcrumbs.html'
'../../components/chunks/breadcrumbs/breadcrumbs.html'
'./../../components/chunks/breadcrumbs/breadcrumbs.html'
'../../../components/chunks/breadcrumbs/breadcrumbs.html'
'./../../../components/chunks/breadcrumbs/breadcrumbs.html'
'../../../../components/chunks/breadcrumbs/breadcrumbs.html'
При любом уровне вложенности нужно получить
components/chunks/breadcrumbs/breadcrumbs.html
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)