# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(ABCD[\w\s]+)( [a-zA-Z]+)$/\1 CONSTANT\2/gm;t' <<< "(C_ABCD_ehfjdhf dj hfdjhfhj and
(S_dfdfdddff 20 and
(P_ABCD_fmngfngm gfnm and"