package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ABCD[\w\s]+)( [a-zA-Z]+)$`)
var str = `(C_ABCD_ehfjdhf dj hfdjhfhj and
(S_dfdfdddff 20 and
(P_ABCD_fmngfngm gfnm and`
var substitution = "\1 CONSTANT\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}