const regex = /(ABCD[\w\s]+)( [a-zA-Z]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ABCD[\\w\\s]+)( [a-zA-Z]+)$', 'gm')
const str = `(C_ABCD_ehfjdhf dj hfdjhfhj and
(S_dfdfdddff 20 and
(P_ABCD_fmngfngm gfnm and`;
const subst = `\1 CONSTANT\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);