import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(ABCD[\\w\\s]+)( [a-zA-Z]+)$";
final String string = "(C_ABCD_ehfjdhf dj hfdjhfhj and\n"
+ "(S_dfdfdddff 20 and\n"
+ "(P_ABCD_fmngfngm gfnm and";
final String subst = "\\1 CONSTANT\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}