import re
regex = re.compile(r"(ABCD[\w\s]+)( [a-zA-Z]+)$", flags=re.MULTILINE)
test_str = ("(C_ABCD_ehfjdhf dj hfdjhfhj and\n"
"(S_dfdfdddff 20 and\n"
"(P_ABCD_fmngfngm gfnm and")
subst = "\\1 CONSTANT\\2"
result = regex.sub(subst, test_str)
if result:
print(result)