use strict;
my $str = '(C_ABCD_ehfjdhf dj hfdjhfhj and
(S_dfdfdddff 20 and
(P_ABCD_fmngfngm gfnm and';
my $regex = qr/(ABCD[\w\s]+)( [a-zA-Z]+)$/mp;
my $subst = '\\1 CONSTANT\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";