$re = '/(ABCD[\w\s]+)( [a-zA-Z]+)$/m';
$str = '(C_ABCD_ehfjdhf dj hfdjhfhj and
(S_dfdfdddff 20 and
(P_ABCD_fmngfngm gfnm and';
$subst = "\1 CONSTANT\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;