# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[@#$%^&+=])[^\s]{8,}$/\1 \2 \1\/\3*100/mg;t' <<< "123456789aA@
1234567
123456789A@
123456789a@
123456789aA
asdasdasd1A#"