#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[@#$%^&+=])[^\s]{8,}$"
Local $sString = "123456789aA@" & @CRLF & _
"1234567" & @CRLF & _
"123456789A@" & @CRLF & _
"123456789a@" & @CRLF & _
"123456789aA" & @CRLF & _
"asdasdasd1A#"
Local $sSubst = "\1 \2 \1/\3*100"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)