import Foundation
let pattern = ##"^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[@#$%^&+=])[^\s]{8,}$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
123456789aA@
1234567
123456789A@
123456789a@
123456789aA
asdasdasd1A#
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \2 \1/\3*100"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)