import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[@#$%^&+=])[^\\s]{8,}$";
final String string = "123456789aA@\n"
+ "1234567\n"
+ "123456789A@\n"
+ "123456789a@\n"
+ "123456789aA\n"
+ "asdasdasd1A#";
final String subst = "\\1 \\2 \\1/\\3*100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}