$re = '/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[@#$%^&+=])[^\s]{8,}$/m';
$str = '123456789aA@
1234567
123456789A@
123456789a@
123456789aA
asdasdasd1A#';
$subst = "\1 \2 \1/\3*100";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;