re = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[@#$%^&+=])[^\s]{8,}$/m
str = '123456789aA@
1234567
123456789A@
123456789a@
123456789aA
asdasdasd1A#'
subst = '\\1 \\2 \\1/\\3*100'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result