use strict;
my $str = '123456789aA@
1234567
123456789A@
123456789a@
123456789aA
asdasdasd1A#';
my $regex = qr/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[@#$%^&+=])[^\s]{8,}$/mp;
my $subst = '\\1 \\2 \\1/\\3*100';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";