#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([A-Z]\d{1,2}|[A-Z]{2}\d(\d|[A-Z])?)( \d[A-Z]{2})?$"
Local $sString = "1 Letter 1 Number" & @CRLF & _
"E2" & @CRLF & _
"1 Letter 2 Numbers" & @CRLF & _
"E22" & @CRLF & _
"2 Letters 1 Number" & @CRLF & _
"EE2" & @CRLF & _
"2 Letters 1 Number 1 Letter" & @CRLF & _
"EE2E" & @CRLF & _
"2 Letters 2 Numbers" & @CRLF & _
"EE22" & @CRLF & _
"1 Letter 1 Number (Space) 1 Number 2 Letters" & @CRLF & _
"E2 2EE" & @CRLF & _
"1 Letter 2 Numbers (Space) 1 Number 2 Letters" & @CRLF & _
"E22 2EE" & @CRLF & _
"2 Letters 1 Number (Space) 1 Number 2 Letters" & @CRLF & _
"EE2 2EE" & @CRLF & _
"2 Letters 1 Number 1 Letter (Space) 1 Number 2 Letters" & @CRLF & _
"EE2E 2EE" & @CRLF & _
"2 Letters 2 Numbers (Space) 1 Number 2 Letters" & @CRLF & _
"EE22 2EE" & @CRLF & _
"" & @CRLF & _
"6FW OX28" & @CRLF & _
"82XO 6FW" & @CRLF & _
"OX28 6FW" & @CRLF & _
"" & @CRLF & _
"E2E" & @CRLF & _
"E22E" & @CRLF & _
"E33 33E"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")