import re
regex = re.compile(r"^([A-Z]\d{1,2}|[A-Z]{2}\d(\d|[A-Z])?)( \d[A-Z]{2})?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("1 Letter 1 Number\n"
"E2\n"
"1 Letter 2 Numbers\n"
"E22\n"
"2 Letters 1 Number\n"
"EE2\n"
"2 Letters 1 Number 1 Letter\n"
"EE2E\n"
"2 Letters 2 Numbers\n"
"EE22\n"
"1 Letter 1 Number (Space) 1 Number 2 Letters\n"
"E2 2EE\n"
"1 Letter 2 Numbers (Space) 1 Number 2 Letters\n"
"E22 2EE\n"
"2 Letters 1 Number (Space) 1 Number 2 Letters\n"
"EE2 2EE\n"
"2 Letters 1 Number 1 Letter (Space) 1 Number 2 Letters\n"
"EE2E 2EE\n"
"2 Letters 2 Numbers (Space) 1 Number 2 Letters\n"
"EE22 2EE\n\n"
"6FW OX28\n"
"82XO 6FW\n"
"OX28 6FW\n\n"
"E2E\n"
"E22E\n"
"E33 33E")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")