use strict;
my $str = '1 Letter 1 Number
E2
1 Letter 2 Numbers
E22
2 Letters 1 Number
EE2
2 Letters 1 Number 1 Letter
EE2E
2 Letters 2 Numbers
EE22
1 Letter 1 Number (Space) 1 Number 2 Letters
E2 2EE
1 Letter 2 Numbers (Space) 1 Number 2 Letters
E22 2EE
2 Letters 1 Number (Space) 1 Number 2 Letters
EE2 2EE
2 Letters 1 Number 1 Letter (Space) 1 Number 2 Letters
EE2E 2EE
2 Letters 2 Numbers (Space) 1 Number 2 Letters
EE22 2EE
6FW OX28
82XO 6FW
OX28 6FW
E2E
E22E
E33 33E';
my $regex = qr/^([A-Z]\d{1,2}|[A-Z]{2}\d(\d|[A-Z])?)( \d[A-Z]{2})?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}