using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z]\d{1,2}|[A-Z]{2}\d(\d|[A-Z])?)( \d[A-Z]{2})?$";
string input = @"1 Letter 1 Number
E2
1 Letter 2 Numbers
E22
2 Letters 1 Number
EE2
2 Letters 1 Number 1 Letter
EE2E
2 Letters 2 Numbers
EE22
1 Letter 1 Number (Space) 1 Number 2 Letters
E2 2EE
1 Letter 2 Numbers (Space) 1 Number 2 Letters
E22 2EE
2 Letters 1 Number (Space) 1 Number 2 Letters
EE2 2EE
2 Letters 1 Number 1 Letter (Space) 1 Number 2 Letters
EE2E 2EE
2 Letters 2 Numbers (Space) 1 Number 2 Letters
EE22 2EE
6FW OX28
82XO 6FW
OX28 6FW
E2E
E22E
E33 33E";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}