const regex = /^([A-Z]\d{1,2}|[A-Z]{2}\d(\d|[A-Z])?)( \d[A-Z]{2})?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z]\\d{1,2}|[A-Z]{2}\\d(\\d|[A-Z])?)( \\d[A-Z]{2})?$', 'gmi')
const str = `1 Letter 1 Number
E2
1 Letter 2 Numbers
E22
2 Letters 1 Number
EE2
2 Letters 1 Number 1 Letter
EE2E
2 Letters 2 Numbers
EE22
1 Letter 1 Number (Space) 1 Number 2 Letters
E2 2EE
1 Letter 2 Numbers (Space) 1 Number 2 Letters
E22 2EE
2 Letters 1 Number (Space) 1 Number 2 Letters
EE2 2EE
2 Letters 1 Number 1 Letter (Space) 1 Number 2 Letters
EE2E 2EE
2 Letters 2 Numbers (Space) 1 Number 2 Letters
EE22 2EE
6FW OX28
82XO 6FW
OX28 6FW
E2E
E22E
E33 33E`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}