// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^([A-Z]\d{1,2}|[A-Z]{2}\d(\d|[A-Z])?)( \d[A-Z]{2})?$").unwrap();
let string = "1 Letter 1 Number
E2
1 Letter 2 Numbers
E22
2 Letters 1 Number
EE2
2 Letters 1 Number 1 Letter
EE2E
2 Letters 2 Numbers
EE22
1 Letter 1 Number (Space) 1 Number 2 Letters
E2 2EE
1 Letter 2 Numbers (Space) 1 Number 2 Letters
E22 2EE
2 Letters 1 Number (Space) 1 Number 2 Letters
EE2 2EE
2 Letters 1 Number 1 Letter (Space) 1 Number 2 Letters
EE2E 2EE
2 Letters 2 Numbers (Space) 1 Number 2 Letters
EE22 2EE
6FW OX28
82XO 6FW
OX28 6FW
E2E
E22E
E33 33E";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}