package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(^F.*$)|(^BBC.*$))`)
var str = `F1
BBC450
BBC566
F2
F31
SOMETHING123
SOMETHING456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}