// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:(^F.*$)|(^BBC.*$))").unwrap();
let string = "F1
BBC450
BBC566
F2
F31
SOMETHING123
SOMETHING456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}