const regex = /(?:(^F.*$)|(^BBC.*$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(^F.*$)|(^BBC.*$))', 'gm')
const str = `F1
BBC450
BBC566
F2
F31
SOMETHING123
SOMETHING456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}