re = /(?:(^F.*$)|(^BBC.*$))/m
str = 'F1
BBC450
BBC566
F2
F31
SOMETHING123
SOMETHING456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end