$re = '/(?:(^F.*$)|(^BBC.*$))/m';
$str = 'F1
BBC450
BBC566
F2
F31
SOMETHING123
SOMETHING456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);