# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((['"])(?:(?!\2|\\).|\\.)*\2)|\\/\\/[^\n]*|\\/\*(?:[^*]|\*(?!\\/))*\*\\//$1/g;t' <<< "String somestring = \"http://google.com\"; // \"//google.com\";\" is going to be removed
get.setHeader(\"Accept\", \"*/*\"); // \"/*\");\" and later is going to be removed too
somemethod();//it should be removed
somemethod(); /* some comment that may end on other line */
String somestring = \"http://google.com\"; // url shouldn't be touched
get.setHeader(\"Accept\", \"*/*\"); // \"*/*\" shouldn't be touched too"