import re
regex = re.compile(r"((['\"])(?:(?!\2|\\).|\\.)*\2)|\/\/[^\n]*|\/\*(?:[^*]|\*(?!\/))*\*\/")
test_str = ("String somestring = \"http://google.com\"; // \"//google.com\";\" is going to be removed\n\n"
"get.setHeader(\"Accept\", \"*/*\"); // \"/*\");\" and later is going to be removed too\n\n"
"somemethod();//it should be removed\n"
"somemethod(); /* some comment that may end on other line */\n"
"String somestring = \"http://google.com\"; // url shouldn't be touched\n"
"get.setHeader(\"Accept\", \"*/*\"); // \"*/*\" shouldn't be touched too")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)