const regex = /((['"])(?:(?!\2|\\).|\\.)*\2)|\/\/[^\n]*|\/\*(?:[^*]|\*(?!\/))*\*\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([\'"])(?:(?!\\2|\\\\).|\\\\.)*\\2)|\\\/\\\/[^\\n]*|\\\/\\*(?:[^*]|\\*(?!\\\/))*\\*\\\/', 'g')
const str = `String somestring = "http://google.com"; // "//google.com";" is going to be removed
get.setHeader("Accept", "*/*"); // "/*");" and later is going to be removed too
somemethod();//it should be removed
somemethod(); /* some comment that may end on other line */
String somestring = "http://google.com"; // url shouldn't be touched
get.setHeader("Accept", "*/*"); // "*/*" shouldn't be touched too`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);