import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((['\"])(?:(?!\\2|\\\\).|\\\\.)*\\2)|\\/\\/[^\\n]*|\\/\\*(?:[^*]|\\*(?!\\/))*\\*\\/";
final String string = "String somestring = \"http://google.com\"; // \"//google.com\";\" is going to be removed\n\n"
+ "get.setHeader(\"Accept\", \"*/*\"); // \"/*\");\" and later is going to be removed too\n\n"
+ "somemethod();//it should be removed\n"
+ "somemethod(); /* some comment that may end on other line */\n"
+ "String somestring = \"http://google.com\"; // url shouldn't be touched\n"
+ "get.setHeader(\"Accept\", \"*/*\"); // \"*/*\" shouldn't be touched too";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}