using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((['""])(?:(?!\2|\\).|\\.)*\2)|\/\/[^\n]*|\/\*(?:[^*]|\*(?!\/))*\*\/";
string substitution = @"$1";
string input = @"String somestring = ""http://google.com""; // ""//google.com"";"" is going to be removed
get.setHeader(""Accept"", ""*/*""); // ""/*"");"" and later is going to be removed too
somemethod();//it should be removed
somemethod(); /* some comment that may end on other line */
String somestring = ""http://google.com""; // url shouldn't be touched
get.setHeader(""Accept"", ""*/*""); // ""*/*"" shouldn't be touched too";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}