use strict;
my $str = 'String somestring = "http://google.com"; // "//google.com";" is going to be removed
get.setHeader("Accept", "*/*"); // "/*");" and later is going to be removed too
somemethod();//it should be removed
somemethod(); /* some comment that may end on other line */
String somestring = "http://google.com"; // url shouldn\'t be touched
get.setHeader("Accept", "*/*"); // "*/*" shouldn\'t be touched too';
my $regex = qr/((['"])(?:(?!\2|\\).|\\.)*\2)|\/\/[^\n]*|\/\*(?:[^*]|\*(?!\/))*\*\//p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";