re = /((['"])(?:(?!\2|\\).|\\.)*\2)|\/\/[^\n]*|\/\*(?:[^*]|\*(?!\/))*\*\//
str = 'String somestring = "http://google.com"; // "//google.com";" is going to be removed
get.setHeader("Accept", "*/*"); // "/*");" and later is going to be removed too
somemethod();//it should be removed
somemethod(); /* some comment that may end on other line */
String somestring = "http://google.com"; // url shouldn\'t be touched
get.setHeader("Accept", "*/*"); // "*/*" shouldn\'t be touched too'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result