#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(yo)?u('re| are|r)? (an? )?idiot"
Local $sString = "you're an idiot" & @CRLF & _
"u're a idiot" & @CRLF & _
"u are idiot" & @CRLF & _
"ur an idiot" & @CRLF & _
"you idiot" & @CRLF & _
"u idiot" & @CRLF & _
"ur idiot" & @CRLF & _
"u an idiot" & @CRLF & _
"you are an idiot" & @CRLF & _
"u're idiot"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")