package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(yo)?u('re| are|r)? (an? )?idiot`)
var str = `you're an idiot
u're a idiot
u are idiot
ur an idiot
you idiot
u idiot
ur idiot
u an idiot
you are an idiot
u're idiot`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}