import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(yo)?u('re| are|r)? (an? )?idiot";
final String string = "you're an idiot\n"
+ "u're a idiot\n"
+ "u are idiot\n"
+ "ur an idiot\n"
+ "you idiot\n"
+ "u idiot\n"
+ "ur idiot\n"
+ "u an idiot\n"
+ "you are an idiot\n"
+ "u're idiot";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}