using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(yo)?u('re| are|r)? (an? )?idiot";
string input = @"you're an idiot
u're a idiot
u are idiot
ur an idiot
you idiot
u idiot
ur idiot
u an idiot
you are an idiot
u're idiot";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}