const regex = /(yo)?u('re| are|r)? (an? )?idiot/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(yo)?u(\'re| are|r)? (an? )?idiot', 'gmi')
const str = `you're an idiot
u're a idiot
u are idiot
ur an idiot
you idiot
u idiot
ur idiot
u an idiot
you are an idiot
u're idiot`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}