$re = '/(yo)?u(\'re| are|r)? (an? )?idiot/mi';
$str = 'you\'re an idiot
u\'re a idiot
u are idiot
ur an idiot
you idiot
u idiot
ur idiot
u an idiot
you are an idiot
u\'re idiot';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);