re = /(yo)?u('re| are|r)? (an? )?idiot/mi
str = 'you\'re an idiot
u\'re a idiot
u are idiot
ur an idiot
you idiot
u idiot
ur idiot
u an idiot
you are an idiot
u\'re idiot'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end