#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\(([a-z -]+)\w+?(\d+)\W+\1\w+\)"
Local $sString = "(beginner_post12 - beginner_baseline)" & @CRLF & _
"(intermediate_post5 - intermediate_baseline)" & @CRLF & _
"(framework notes_posttest4 - framework notes_baseline)" & @CRLF & _
"(note-taking instruction_posttest33 - note-taking instruction_baseline)" & @CRLF & _
""
Local $sSubst = "Gain_$2($1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)