import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(([a-z -]+)\\w+?(\\d+)\\W+\\1\\w+\\)";
final String string = "(beginner_post12 - beginner_baseline)\n"
+ "(intermediate_post5 - intermediate_baseline)\n"
+ "(framework notes_posttest4 - framework notes_baseline)\n"
+ "(note-taking instruction_posttest33 - note-taking instruction_baseline)\n";
final String subst = "Gain_$2($1)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}