const regex = /\(([a-z -]+)\w+?(\d+)\W+\1\w+\)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(([a-z -]+)\\w+?(\\d+)\\W+\\1\\w+\\)', 'gmi')
const str = `(beginner_post12 - beginner_baseline)
(intermediate_post5 - intermediate_baseline)
(framework notes_posttest4 - framework notes_baseline)
(note-taking instruction_posttest33 - note-taking instruction_baseline)
`;
const subst = `Gain_$2($1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);