$re = '/\(([a-z -]+)\w+?(\d+)\W+\1\w+\)/mi';
$str = '(beginner_post12 - beginner_baseline)
(intermediate_post5 - intermediate_baseline)
(framework notes_posttest4 - framework notes_baseline)
(note-taking instruction_posttest33 - note-taking instruction_baseline)
';
$subst = "Gain_$2($1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;